NTX FAC Alert - URGENT - RBC errors
Incident Report for FAC RBC
Resolved
This incident has been resolved.
Posted Feb 02, 2023 - 21:18 UTC
Investigating
We are currently investigating this issue.
Posted Feb 02, 2023 - 21:00 UTC
This incident affected: RBC Outage Merchants (RBC Outage).